Question Low TPS after updating to 1.19.2 / 1.19.4

KimiD2007

New member
Feb 24, 2024
3
0
1
Hello there!
Recently, I have updated my (paper) server from 1.19 to 1.19.2 and shortly after that 1.19.4.
Ever since I have updated to 1.19.2, my server reaches a tps amount of as low as 9, with the average being around 10-13.
I have absolutely no clue why the TPS went down, and I also don't know much about server configs.
Only thing I do know is that the server ran just fine when I had 1.19 installed.
I do know that 1.19 Paper is an unsupported version, though I would still like to ask, as I can't seem to find a fix for it.

The CPU Usage is about 80%, idk if that's good, avg or bad
I have about 19 different worlds loaded on the server, but usually, one 2-3 at max are loaded actively. Shouldn't be a problem, as the server ran just fine with this many worlds before I updated the version.
I did change from paper to forge a few days ago, that was only for a quick check abt a mod. I changed back to paper after I realized I didn't need the mod in the first place.
You can see the logs attached.
I really appreciate anyone who might be able to help.
 
Logs
https://paste.gg/p/anonymous/9eb972a7035044d6b0af952b3a328f9e
Version Output
This server is running Paper version git-Paper-550 (MC: 1.19.4) (Implementing API version 1.19.4-R0.1-SNAPSHOT) (Git: 483368e on ver/1.19.4)
You are running the latest version
Previous version: git-Paper-246 (MC: 1.19.2)

electronicboy

Administrator
Staff member
Dec 11, 2021
255
15
45
28
for 1.19.x? it gives you a years worth of performance improvements made to the server software by us and mojang, outdated versions are also generally a pita to support as stuff changes and so most of us generally do not care to provide support for outdated versions
 

KimiD2007

New member
Feb 24, 2024
3
0
1
for 1.19.x? it gives you a years worth of performance improvements made to the server software by us and mojang, outdated versions are also generally a pita to support as stuff changes and so most of us generally do not care to provide support for outdated versions
If you say so I guess I'll try it
Let's hope it fixes that
 

electronicboy

Administrator
Staff member
Dec 11, 2021
255
15
45
28
I mean, it's not a magical fix, you'd need to look into providing diagnostics information such as spark reports, but people are generally not inclined to bother digging into them on unsupported versions
 
  • Like
Reactions: KimiD2007