Plugin Release AuthMeVelocity | AuthmeReloaded support for Velocity

Download Link
https://github.com/4drian3d/AuthMeVelocity/releases
Source Code
https://github.com/4drian3d/AuthMeVelocity/
Documentation
https://github.com/4drian3d/AuthMeVelocity/wiki/
Support
https://discord.gg/5NMMzK5mAn
Minecraft Versions
Velocity 3.1.2+ | Paper 1.13+
Compatible Java Versions
Java 17+
AuthMeVelocity
This plugin adds the support for Velocity to AuthMeReloaded

Requirements
  • Paper, Pufferfish, Purpur (or any Paper-fork 1.13+)
  • Velocity 3.1.2+
  • Java 17

Features
  • Adds AuthmeReloaded support to Velocity
  • Prevents command execution, server switching, chat and more through Velocity in case the player is not logged in.
  • Send your players to another server after logging in (configurable). Fix AuthmeReloaded problem
  • Get API support for players logged in from Velocity!
  • FastLogin Velocity Support

Setup
1. Download the latest release of the plugin link
2. Put the plugin in the Velocity plugins folder and on all your Auth servers that have AuthMe installed.
3. Start the Velocity proxy and set up the config.conf with the auth servers

Plugin API
Check the plugin API here

Configuration
Check the plugin configuration here

Discord Support Server

This is a fork of the original AuthmeVelocity, which was archived by its author https://github.com/Glyart/AuthMeVelocity
Credits to Glyart for initiating this plugin.
 
Last edited:

4drian3d

New member
Jan 5, 2022
15
3
3
Perú
New Update: AuthmeVelocity 3.0.0

This update brings new configuration options, API improvements for Paper and Velocity modules, performance improvements, internal refactoring, Minecraft 1.19.1 support and more. It is incompatible with the previous version, so you will have to reconfigure the plugin with the hocon(.conf) format.

The plugin is now distributed as a single file that can be installed on Paper servers version 1.13 or higher (1.12 support likely, not verified or supported) and on Velocity instances version 3.1.2 or higher.

In case you do not use Java 17 or higher, you can still use AuthMeVelocity (spigot/proxy) 2.2.3. This version will continue to be supported until the end of this year and will be updated only if a bug is found

List of changes and download: https://github.com/4drian3d/AuthMeVelocity/releases/tag/3.0.0