Solved TextDecoration Bleed Over

xxCoderforlife

New member
Oct 1, 2022
2
0
1
So when I append a premade TextCompoment to a new one(i.e Sending a prefix before every console message) the TextDecoration (If prefix is bold so is the message but holds the custom color that was set) bleeds through to the message.
I've tried resetting the Style for the message and building it on send but to no avail. Does anyone have any idea on how to fix this
 
Version Output
[14:26:54 INFO]: Checking version, please wait...
[14:26:55 INFO]: This server is running Paper version git-Paper-174 (MC: 1.19.2) (Implementing API version 1.19.2-R0.1-SNAPSHOT) (Git: 01a1387)
You are 15 version(s) behind
Download the new version at: https://papermc.io/downloads
Previous version: git-Paper-173 (MC: 1.19.2)

Noah

Paper Triage
Staff member
Jan 4, 2022
37
2
12
8
The Netherlands
Try appending your prefix to an empty parent component instead, like so:
Java:
Component.empty().append(myPrefixComponent).append(myText)
or use the builder:
Java:
Component.text().append(myPrefixComponent).append(myText).build()
 

xxCoderforlife

New member
Oct 1, 2022
2
0
1
Try appending your prefix to an empty parent component instead, like so:
Java:
Component.empty().append(myPrefixComponent).append(myText)
or use the builder:
Java:
Component.text().append(myPrefixComponent).append(myText).build()
It's for sure a cleaner way of doing it but I'm still getting the bold error.
Edit: It seems to only add the bold decoration when I add the color in from the method. Hmmm
 
Last edited: